1. Velkommen til iExcelbooks.no! Det ser ut som du browser iExcelbooks.no som gjest. Visste du at om du oppretter en konto/medlemskap, får du tilgang til flere forskjellige privilegier, og i tillegg har du mulighet til å delta i diskusjoner på forum. Du vil også få tilgang til alle verktøy og kunnskap som iExcelbooks tilbyr.
    Fjern notisen

Formel som henter info med gitt avstand celler

En tråd i 'Excel - formler og funksjoner' startet av tsosen, 16 Feb 2010.

Trådstatus:
Stengt for ytterligere svar.
  1. tsosen

    tsosen New Member

    Celle V4 =SUMMER(d!$Y2:$Y49)

    Celle V5 =SUMMER(d!$Y338:$Y385)

    Celle V6 =SUMMER(d!$Y674:$Y721)



    Dette er hvordan jeg vil at formelen skal løpe



    Men når jeg forsøker å trekke ut formelen videre klarer den å gi følgende formel



    Celle V7 =SUMMER(d!$Y5:$Y52)



    Noen som vet hvordan jeg løser dette?
     
  2. admin

    admin Guest Staff Member

    Excel lager en listen ut fra hvor mange rader du kopierer ned. Siden V7 er 3 rader nedenfor V4, og de relative referansene blir dermed kun akkumulert med 3.



    Jeg er tilhenger av å bruke mellomberegninger i hjelpeceller og -kolonner.



    Her får du kanskje løst utfordringen ved å lage hjelpeberegning i kolonne Z hvor du rett og slett i celle Z49 lager formelen =Summer(Y2:Y49). Kopierer du deretter denne formelen ned til celle Z385 skal du etter mine beregninger kunne markere området Z50:Z385 og dobbelklikke på fyllhåndtaket for å få formelen til å kopieres ned i det riktige intervall (siden intervallet er fast).



    Alternativt kan du lage en kolonne, f.eks. AA, som fungerer som en referanse, hvor radene 2:49 får referansen 1, radene 338:385 får referansen 2 og 674:721 får referansen 3 osv. Referansen kan legges inn manuelt (tungvint) eller som en formel.

    Lag denne databasen i Ark2:



    Tekst i B2: Interval Start

    Tekst i C2: Interval Slutt

    Tekst i D2: Intervall nr.



    Celle B3 og C3 er 2 og 49 og celle D3 = 1 ($D1+1) hvor D1 er 0

    Celle B4 og C4 er 50 og 337 og celle D4 = 0

    Celle B5 og C5 er 338 og 385 og celle D5 = 2 ($D3+1)

    Celle B6 og C6 er 386 og 673 og celle D6 = 0

    Celle B7 og C7 er 674 og 721 og celle D7 = 3 ($D5+1)



    I kolonne celle AA2 skriver du da inn følgende formel

    =FINN.RAD(RAD(aa2);Ark2!B:D;3)



    I Finn.RAD-funksjonen kan du IKKE skrive USANN som siste argument. Det må stå SANN eller være utelatt (slik jeg har gjort).



    Når det står nummer i celler med faste intervall, slik som i cellene B3:B7 og C3:C7 i Ark2, vil de bli regnet som liste, og vil akkumulere seg ved kopiering nedover slik du ønsker.



    Kanskje ikke den beste løsningen? Men den skal i hvert fall fungere, og det er det viktigste.



    :)
     
Trådstatus:
Stengt for ytterligere svar.

Del denne siden